...

или внеочередные заметки


Previous Entry Share Next Entry
Опции и параметры configure для тестирования постгреса
trekking, Himalaya
obartunov
Мне приходится иной раз тестировать разные наработки наших ребят и приходится быть аккуратным, чтобы не запутаться среди разных веток в нашем гите. Недавно я узнал про возможность задания дополнительной информации в версию с помощью опции --with-extra-version для configure. Через пару минут моя строчка для configure теперь выглядит так:

./configure --prefix=/usr/local/pgsql-head --enable-depend --with-pgport=5555 CPPFLAGS="-I$(brew --prefix readline)/include" LDFLAGS="-L$(brew --prefix readline)/lib" --with-python --with-perl --with-extra-version=-`git rev-parse --abbrev-ref HEAD`/`git rev-parse --short HEAD`

и все постгресовые утилиты с --version выдают вот такую строку

psql --version
psql (PostgreSQL) 10devel-CORE-363-atx/baa5fd2


psql testatx
Null display is "(null)".
Timing is on.
Pager is always used.
psql (10devel-CORE-363-atx/baa5fd2)
Type "help" for help.

[local]:5555 postgres@testatx=# select version();
                                                                version
---------------------------------------------------------------------------------------------------------------------------------------
 PostgreSQL 10devel-CORE-363-atx/baa5fd2 on x86_64-apple-darwin16.1.0, compiled by Apple LLVM version 8.0.0 (clang-800.0.42.1), 64-bit
(1 row)


Теперь уже я не потеряюсь.

PS. Заморочки с brew вызваны тем, что в макоси libreadline на самом деле libedit и приходится использовать вот такую комбинацию, чтобы линковаться с правильной библиотекой.
Tags:

?

Log in

No account? Create an account